Linux-compatible wireless USB adaptor that I can actually buy?

Has anyone bought a USB WiFi adaptor (54 speed rather than 11, ideally), in the last few months that actually works with Linux (preferably Ubuntu) without using the Windows driver via ndiswrapper?

There are several reports of adaptors that worked out-of-the-box but all those adaptors now seem to be sold with the same model names, but with different chipsets that don’t have Linux drivers.

Or even a PCI card? They keep changing those chipsets too.

25 thoughts on “Linux-compatible wireless USB adaptor that I can actually buy?

  1. I bought a Belkin wireless USB adaptor capable of going at wireless 54g speeds a few months ago. It seems to use a Ralink chipset, and to get it to work, I had to check the source out of CVS from a Sourceforge project and compile it, but it runs absolutely stably (over weeks of time). The only other shortcoming is that its wireless extension support is less than version 18, so WPA won’t work, but WEP works perfectly.

    Email if you want more details about it.

  2. Simos, well yes, if I knew what chipset the cards had before I bought them then this would all be much easier. But that’s not generally possible, because the manufacturers often change the chipsets without changing the model names.

  3. I’ve bought the Belkin Emily is referring to but they changed the chipset in mine. I now bought the ASUS 167-g which has a Ralink chipset. It works fine on Ubuntu.

    A tip go to the manufacturers site and download the windows drivers and look if the inf file and look if it refers to the ralink drivers.

    Note the new ASUS 167-gE has a broadcom chipset. So buy the old one

  4. Here is a tip.

    Buy from your local stores what you think will work. When it doesn’t return it for refund and tell them why. No Linux support. Everyone needs to start making more noise about this issue. It is the only way things will change.

    Make it a hassle for the store and they will in turn put pressure on the distributors and manufacturers.

    Cheers

  5. Hi Murray,
    I recently bought a 54Mbps USB adapter D-Link DWL-122 rev.C1 (S/N: DR55264077303, UPC code (EU): 79006926985) for my brother. It doesn’t work out of the box with ubuntu, but you can grab and compile the open source driver from http://rt2x00.serialmonkey.com (not yet in kernel tree). It doesn’t work with Network Manager (not tested latest driver versions) and I have problems if I enable WPA for my network (so it is open and free for almost everyone who come here and put his car in front of my house :). There are some howtos for this USB adapter on ubuntuforums or other places.

  6. murrayc: I also strongly suggest a zd1211 based stick. I have had a good amount of research into which devices are acceptable, and it seems rt2x00 is kind of dead (and doesn’t support WPA with wireless-extensions), Conexant (FreeMAC/SoftMAC) based devices don’t support wireless-extensions don’t support WPA this way as well.

    The above mentioned zd1211 site has a pretty complete list of devices containing a zd1211 chip, and it also mentions if there are different versions which may not work with the zd1211 driver. I have come to the conclusion that a zd1211 based device is the only feasible solution, even if it doesn’t yet support some minor features like automatic rate management.

    As for Ubuntu – Edgy has a quite early version of the zd1211rw driver (which actually works, as opposed to the original community driver in pre-Edgy, I didn’t get that one to work). Because the zd1211rw driver is that early, it doesn’t register itself for all the devices that it supports. So if you really need it working with Edgy out of the box, you’d better look inside Edgy’s kernel sources (drivers/net/wireless/zd1211rw/zdusb.c) and compare those identifiers with the ones on the zd1211 site so that you know which device works together with Edgy’s standard kernel. If you’ve got a different one, it’s still not difficult to add the identifier of another device and recompile the kernel module, it just takes a little more work.

    So, if you want a stick that I can promise to work in any case (it only has got one version and is registered with Edgy’s kernel), get the MSI US54SE, I bought that one last week for a friend of mine. Also, all of the devices with the 0ace:1211 identifier also work in Edgy out of the box.

    Seems a little complicated and I guess it is, but look to the other drivers and you’ll see that you’ve really got no option than to buy one of the zd1211 ones.

  7. I’ve got a Netgear WG311v2 PCI card that worked out of the box on Ubuntu Edgy.
    I should note: Don’t get the WG311v3.. it doesn’t work even with ndiswrapper.

    The Netgear WG111v2 USB wireless adapter also worked out of the box on Ubuntu Edgy for me.

  8. Jakob, thanks. Interestingly, there’s not one single listed zd1211 USB card that is available on both Amazon.com and Amazon.de, so it’s hard to recommend something for everyone. At least the MSI US54SE that you mentioned is available in Germany.

  9. Thilo, thanks, but they don’t have any USB or PCI adaptors that just work. At the least they need self-compiled beta drivers or ndiswrapper. I don’t think any of them are likely to work at all in Ubuntu Edgy.

  10. I have tried everything I can find to get my new Belkin USB wireless to work on my amd64 Ubuntu box. Tried native drivers and ndiswrapper. How do I know what kind of chipset I am using? With ndiswrappers it says driver loaded hardware present but then when I do a modprobe ndiswrapper I get a fatal error. I’d move on to a different pci card but I’m already using the two pci slots on my PC. Any ideas would be appreciated.

  11. OK got past the last error by switching from ndiswrapper 1.7 to 1.8. Now when I do a modprobe ndiswrapper no error message. GREAT.

    ndiswrapper -l gives : driver rt73 present/hardware present

    BUT

    iwconfig gives me nothing in the way of a wireless interface. Just no wireless extensions listed for loopback, all virtual interfaces (using vmware) and one NIC. Anyone with any ideas?

  12. I bought a Linksys Gaming Adapter (WGA54G) and configured it with my windows PC for video game console to internet use, then plugged it in the back of my Linux PC and it worked without any further problems. The configuration was just to enter the wireless addess of your router and problem solved. I used danw’s help above when he said the D-link Gaming Adapter would work, they were sold out, so I tried the Linksys and it worked as well.

  13. > George Says:
    >
    >
    > Buy from your local stores what you think will work. When it doesn’t return it for refund and tell
    > them why. No Linux support. Everyone needs to start making more noise about this issue.
    > It is the only way things will change.
    >
    > Make it a hassle for the store and they will in turn put pressure on the distributors and manufacturers.

    Maybe someone should compile a list of hardware suspected of being incompatible and then target those devices for purchase on every 1st Friday of the month. If the device doesn’t not work with Linux, then there will be 1000 to 50,000 returns over the same weekend.

    Might send a point.

  14. My Gigafast WF748-CUI USB wifi stick is now working! It’s $17 at windmilltrading.com, and uses the ZD1211RW driver. Apparently Gigafast changed the RF chip (without changing the model number, grrr), but the new one works if you get the newest Linux 2.6.21 and patch it with the AL2230S-support patch, which will be included standard on Linux 2.6.22. So here were my steps to get USB Wifi on Linux:
    – buy the Gigafast stick
    – download firmware from link at http://zd1211.ath.cx
    – install firmware by untarring it in /lib/firmware
    – download Linux 2.6.21 kernel source from http://kernel.org
    – patch Linux 2.6.21 kernel source with AL2230S-support patch from http://marc.info/?l=linux-netdev&m=117364295516100&q=raw
    – compile new kernel
    – enjoy your new usb wifi interface
    (patching/compiling steps will become unnecessary after kernel 2.6.22 is released)

  15. As allready mentioned you could try the zd1211 based (Edimax 7137UG for example) ot the rt2500 based.

    im using it (zd1211) bougth it for approximatly 150 NIS (30USD)

Leave a Reply to Jakob Petsovits Cancel reply

Your email address will not be published. Required fields are marked *